LIVE Link Delivery Issue: Outlook, MSN, LIVE, and Hotmail Email Addresses
Incident Report for FitGrid
Resolved
This incident has been resolved.
Posted Sep 22, 2022 - 16:29 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 22, 2022 - 15:57 EDT
Investigating
We are currently investigating this issue.
Posted Sep 22, 2022 - 13:06 EDT
This incident affected: FitGrid LIVE Web App.